【Unity2020.3】Google Play Consoleで「バージョン コード1のAPKまたはAndroid App Bundleがすでに存在するため、別のバージョン コードを使用する必要がありあます。」と出た時の対処

投稿日:2021年5月11日
最終更新日:2021年5月11日

Unityでビルドしたaabファイルをアップロードしたら問題発生

UnityでつくったAndroidゲームをGoogle Playでリリースしようと思ってaab(Android App Bundle)ファイルをアップロードしようとしたところ、以下のように「バージョン コード1のAPKまたはAndroid App Bundleがすでに存在するため、別のバージョン コードを使用する必要がありあます。」というエラーが発生。

このエラーの対策方法をメモしておく。

 

開発環境

Windows 10 Home
Unity 2020.3.1.f1(LTS)

 

Player SettingsからBuild Version Codeを変更する

まずはBuild SettingsからPlayer Settings…を開く。

あとは、Bundel Version Codeを変更してやればOK。私は1になっていたのを2に変更した。なお、上のVersion*の方は変えなくても問題ない。

これで再度ビルドを行い、aabファイルをアップロードしたらエラーは消えた。

0

投稿者: wakky

映画と旅行が大好きなエンジニア。お酒、ゲーム、読書も好き。

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください